[Linux] Eigenen FiveM Server erstellen

  • Hilfe bei mir kommt ein Fehler...

    Creating script environments for _cfx_internal

    Found new resource monitor in /home/gtafivem/server/alpine/opt/cfx-server/citize n//system_resources//monitor

    Found new resource webadmin in /home/gtafivem/server/alpine/opt/cfx-server/citiz en//system_resources//webadmin

    Couldn't find resource sessionmanager.

    Creating script environments for webadmin

    Instantiated instance of script FxWebAdmin.BaseServer.

    Instantiated instance of script FxWebAdmin.HttpServer+HttpServerScript.

    Started resource webadmin

    This server does not have a license key specified. Please set the sv_licenseKey console variable to a key from https://keymaster.fivem.net/. (for example, `set sv_licenseKey "key"` in the config, or `+set sv_licenseKey key` on the command l ine)No such config file: server.cfg

    Stacktrace:


    GlobalError: This server does not have a license key specified. Please set the s v_licenseKey console variable to a key from https://keymaster.fivem.net/. (for e xample, `set sv_licenseKey "key"` in the config, or `+set sv_licenseKey key` on the command line)

    /proc/self/maps:

    4095d000-4096d000 rwxp 00000000 00:00 0

    40b9a000-40c3a000 rwxp 00000000 00:00 0

    41923000-419e3000 rwxp 00000000 00:00 0

    39053500000-39053540000 r--p 00000000 00:00 0

    3d091580000-3d091581000 rw-p 00000000 00:00 0

    77d61300000-77d61340000 rw-p 00000000 00:00 0

    130e51b00000-130e51b40000 rw-p 00000000 00:00 0

    1c846c5c0000-1c846c600000 rw-p 00000000 00:00 0

    20453d210000-20453d218000 rw-p 00000000 00:00 0

    214709200000-214709240000 rw-p 00000000 00:00 0

    24d51e6c0000-24d51e6d6000 rw-p 00000000 00:00 0

    2bb00f4c0000-2bb00f500000 rw-p 00000000 00:00 0

    2c69789e2000-2c6978a00000 ---p 00000000 00:00 0

    2c6978a00000-2c6978a01000 rw-p 00000000 00:00 0

    2c6978a01000-2c6978a02000 ---p 00000000 00:00 0

    2c6978a02000-2c6978a27000 r-xp 00000000 00:00 0

    2c6978a27000-2c6978a3f000 ---p 00000000 00:00 0

    2c6978a3f000-2c69809e2000 ---p 00000000 00:00 0

    555555a0c000-555556e79000 rw-p 00000000 00:00 0 [heap]

    7efcba300000-7efcba400000 rw-p 00000000 00:00 0

    7efcbab00000-7efcbac00000 rw-p 00000000 00:00 0

    7efcbad00000-7efcbae00000 rw-p 00000000 00:00 0

    7efcbaefa000-7efcbb100000 r--p 00000000 fd:07 134023 /home/g tafivem/server/alpine/opt/cfx-server/citizen/clr2/lib/mono/4.5/System.Data.dll

    7efcbb200000-7efcbb300000 rw-p 00000000 00:00 0

    7efcbb3d3000-7efcbb4fe000 rw-p 00000000 00:00 0

    Memory around native instruction pointer (0x7efcd5e10a00):

    0x7efcd5e109f0 00 00 b8 0e 00 00 00 31 d2 bf 02 00 00 00 0f 05 .......1....... .

    0x7efcd5e10a00 c3 48 63 ff 50 b8 24 00 00 00 0f 05 48 89 c7 e8 .Hc.P.$.....H.. .

    0x7efcd5e10a10 d0 9a fd ff 5a c3 48 63 ff 50 48 63 f6 b8 3e 00 ....Z.Hc.PHc..> .

    0x7efcd5e10a20 00 00 0f 05 48 89 c7 e8 b8 9a fd ff 5a c3 85 ff ....H.......Z.. .


    =================================================================

    Got a SIGABRT while executing native code. This usually indicates

    a fatal error in the mono runtime or one of the native libraries

    used by your application.

    =================================================================


    Aborted

  • Hat alles geklappt, nur das Starten möchte nicht.

    Server license key authentication succeeded. Welcome!

    cfx> Sending heartbeat to https://servers-ingress-live.fivem.net/ingress

    Authenticating with Nucleus...

    server thread hitch warning: timer interval of 1373 milliseconds

    Reauthenticating with Nucleus...

    Authenticating with Nucleus failed! That's possibly bad.

    Authenticating with Nucleus failed! That's possibly bad.

  • 005ea6-1590605721.png
    Kennt jemand das Problem?

    Ich würde einfach mal die Resource "Sessionmanager" überprüfen.

    1. Ist sie vorhanden?

    2. Hat sie eine resource.lua?

    3. Hast du am Ende deiner Server.cfg das bekannt "restart sessionmanager"


    Wenn du Punkt 1-3 in der Reihenfolge abarbeitest, sollte sich dein Problem von selbst lösen.

    Falls nicht kann ich er mir gerne nochmal anschauen.


    MFG TretPorsche

  • Guten Abend,


    Vielen Dank für den Input. Ich möchte mir nun gerne auch einen solchen Server auf meinem Linux Server erstellen. :)


    Ich habe drei Fragen:


    1. Was für Anforderungen sollte mein Server haben? CPU, RAM, HDD?


    2. Welche Ports muss ich öffnen, damit ich anderen ermöglichen kann auf meinem Server zu joinen?


    3. Kann ich hier auch problemlos mit Debian arbeiten? (Bevorzuge ich ehrlich gesagt lieber.)


    Vielen lieben Dank!

    Grüße


    Djdonnerwolke

  • Hey,


    Ich versuche dir deine Fragen zu beantworten,


    1. Ich selbst habe momentan 4 Kerne einer Intel Xeon E5-2630 v4 CPU, 8GB DDR4 RAM und eine 100GB HDD. Für das ganze Zahle ich etwa 9€ im Monat was denke ich ein sehr gutes Preis/Leistungs Verhältnis. Die ganze Konfiguration reicht in der Praxis locker für 55-64 Spieler. (Mehr konnte ich leider aufgrund meiner nur 64 Slot Lizenz nicht testen) Darauf kannst du dann locker auch noch die entsprechende DB, eine Website, einen Fileserver für dein Projekt und einen TS hosten. (Läuft bei mir alles ohne Probleme)


    2. Bei mir waren alle Ports soweit schon geöffnet, ansonsten kommt es natürlich darauf an auf welche Ports du deinen FiveM Server legst.


    3. Ich selbst benutze Debian 9 und hatte wie oben schon erwähnt noch keine Probleme diesbezüglich.


    Weitere Fragen kannst du natürlich selbstverständlich stellen.


    MFG TretPorsche

  • Weitere Fragen kannst du natürlich selbstverständlich stellen.


    MFG TretPorsche

    Guten Morgen TretPorsche,


    vielen Dank für deine schnelle Antwort. Damit ist mir schon mal einiges geholfen. Ich komme gerne noch mal darauf zurück.


    Der Server rennt bei mir schon. Wenn ich den Server starten möchte, muss ich folgendes eingeben: bash /root/server/run.sh +exec server.cfg

    (Ich nutze für jeden Dienst einen eigenen Server, deshalb der Root)

    Leider kommt bei mir dann der Fehler

    Der Server ist gestern Abend bzw letzte Nacht einmal gestartet. Aber danach nicht mehr. Meine Konfig:

    Ohne der Variable +exec server.cfg startet zumindest mal der FXServer.

    Einen Key habe ich natürlich installiert. Was ist schief gelaufen?


    Vielen Dank und einen schönen Sonntag! Grüße.

  • Hey djdonnerwolke

    Ich denke ich habe deinen Fehler gefunden.

    Meine Dateistruktur ist so aufgebaut:


    Home -> fivem -> alpine

    -> run.sh


    -> server-data -> recources

    -> server.cfg


    *da ich gerade gesehen hab das meine Dateistruktur leider verschoben ist, hier nochmal als Screenshot (https://prnt.sc/tc79cy) --Ich meine natürlich Resources nicht Recources. Sorry dafür ^^



    Wenn ich jetzt deinen Startbefehl im Ordner "fivem" ausführe, erhalte ich genau den gleichen fehler. (https://prnt.sc/tc75em)


    Du hat den Befehl "+exec server.cfg" in deinem Startcommand, welcher jedoch nur die Datein erfasst welche in dem Ordner sind wo du ihn ausführst. Probier also mal deinen Startcommand in dem Ordner wo auch die Server.cfg gelistet ist, aus zu führen. Das ist in meinem Fall der Ordner "server-data". Mein Startcommand für die Oben beschriebene Dateistruktur ist "../fivem/run.sh +exec server.cfg"


    Ich hoffe ich konnte dir weiter helfen.


    MFG TretPorsche