FiveM Scriptinstallation Unraid/Docker

  • Hallo liebe Community,


    ich bin ja noch recht frisch im Thema FiveM, von daher erstmal mein aktueller Aufbau.


    Host:

    Ded. Unraid server Premium

    24 GB Ram

    2,8GHz Intel I7

    OS in der Docker ist eine Linux Alpine

    FiveM Docker install von ich777 Stable in Version 3404


    Grundinstallation was gerade läuft:

    ESX im Grundgerüsst inkl. ESX_essentials roh.

    Anbindung der Datenbank über zweite Docker (Maria_DB) connected

    MYSQL Adminoberfläche über weitere Docker zu oben benannter Maria_DB connected und administrierbar.

    Db über server.cfg eingebunden und auch anscheinend connected (auszug Serverlog [mysql-async] [SUCCESS][0m Database server connection established.


    Die Info.json gibt nachfolgendes aus:

    Code
    1. {"enhancedHostSupport":true,"resources":["hardcap","esx_menu_dialog","yarn","webpack","fivem-map-skater","esx_menu_list","monitor","vMenu","z-loadscreen","basic-gamemode","mysql-async","es_extended","esx_skin","_cfx_internal","chat","playernames","esx_menu_default","skinchanger","mapmanager","spawnmanager","sessionmanager","rconlog","scoreboard","async","fivem","esx_addonaccount"],"server":"FXServer-master v1.0.0.3404 linux","vars":{"gamename":"gta5","gametype":"Roleplay","locale":"de-DE","onesync_enabled":"false","sv_enforceGameBuild":"1604","sv_enhancedHostSupport":"true","sv_lan":"false","sv_licenseKeyToken":"j3o9tazfats2rot6_1547748:b9532dc9e82b69c26c7e638dcb94bcc5c1ebc21263fb0ad70b91ee269ebcd72c","sv_maxClients":"1000","sv_scriptHookAllowed":"true","tags":"roleplay, military, tanks, drifting, cars, racing"},"version":985356406}


    Nun zu meinem Problemchen:

    Nach meinem Wissen kopiert der Server ja daten in den Cache-Ordner. Obwohl ich diverse Daten (Plugins) neu in Resourcen geladen habe und diese ebenso laut Anleitung in die Server.cfg integriert habe, starten diese nicht. ebenso erscheinen Sie gefühlt nach Tagen erst in dem Cachordner und laufen auch dann erst. Beispiel: ICh hatte das vMenu installiert nach Anleitung (permission datei gesetzt und konfiguriert, Daten kopiert in /resourcen) aber es wollte einfach nicht laufen. Am nächsten morgen kam ich an den Server und siehe da, der vMenu Ordner wurde im Chache-Ordner erstellt und anschließend lief es auch.


    Hat das Problem noch jemand gehabt?

    Gibt es eine Möglichkeit das manuel anzutriggern?


    So habe ich nun mittlerweise 2 Docker mit selbigen anbindungen an verschiedenen DBs um hier und da zu testen.


    Jetzt kommen die blöden Fragen:


    Wie heissen eigentlich die Actionskringel vor den Shops oder anderen Stellen, wo der Spieler über die E-Taste ein Menü aufrufen kann? Kann ich die über die entsprechenden LUAs ändern/versetzen?

    Welche Plugins werden benötigt, damit ich Aktionsmöglickeiten auf der Karte sehe? (gibt es dafür packs oder muss ich jedes einzeln installieren?)

    Aktuell ist mein Spieler als unamployed angegeben und mein nächster schritt war das Jobcenter zu installieren, hat aber nicht geklappt (ES_Joblisting/ES_Jobs) wegen selbigen Problem mit dem Cacheordner.


    So ich mache hier erstmal ein Break und schau mal ob meine vorangegangene Arbeit nicht ganz falsch war.


    Ich danke euch im Voraus

    gruß Zero

  • Das Ding ist einfach, das die meisten hier einfach ZAP-Gameserver hernehmen. Der kleinere Teil seinen eigenen Windows oder Linux Server hat und wenn man schon nen Linux Server hernimmt dann kopieren die meisten ehh nur. Zudem kann ich für meinen Teil sagen, dass ich leider zu wenig Erfahrung mit Docker habe da ich genug Performance habe das sich QEMU-Virtualisierung lohnt.

    Zu der Sache mit den Mapmarkern. Kannst du eigentlich easy in das betroffene Client-Script reinschreiben.